Whats going on with my plant? Help!

Why does my plant look like this? I feel like it should look alot different.

2 Likes

Better check that your air stone is working!!! If not that’s the issue! If it is, it’s def a ph issue

4 Likes

How is it a ph issue because my airstone works and i use ro water so shouldnt the machine automatically fix the ph

1 Like

I agree with @Osage that looks like a stone issue. It’s easy to check both the stone and the pumps 1 to 3 and the cords at the top and around the lid. Easy fix to help your plant

1 Like

Whats your humidity looking like?

No clue

@mary_jane,

Sorry this is happening to you:

((#Ticket)): :ticket::tickets:

https://support.grobo.io

--


((#PhProbe)): ((#PhSensor)):

--

:crossed_fingers::crossed_fingers:


Summary

This ticket was made for Our Blueberry Grow when (I didn’t clean the sensor one day): Just :one: Day:

The Nutrients should be locked in after knowing how well the plant takes to them: We use the same water

every time:

What if we did this?: :question:

:thinking:


((#Welcome)):

:wave::wink:

--


2 Likes

@Osage appears to be right def lack of oxygen

2 Likes

What should i do then? And also does this mean i will have a bad yield?

You’ll lose your plant if it’s the air stone. I would go out spend 20 dollars buy a replacement one and put it in right away…then open a ticket if your covered under warranty and fix the one in your machine

1 Like

Ive done all of that already. Im just curious how i get my plant back on track to where it should be and for a successful yield.

1 Like

Hey @mary_jane,

I’ve responded through our support channel, don’t worry, your yield won’t suffer yet. We got this!

Cheers,
Stephen

5 Likes

You got on it in time. She’ll bounce back :+1::v:

4 Likes

Whats ur temp and humidity. Looks like temp or humidty issue

2 Likes

No idea i thought its hist doing its thing

1 Like

Its your pump trust me, its happened to me & a lot of others on this forum

2 Likes