Soil grow help

I have a soil grow and my plants look off does anyone know what’s wrong with them

1 Like

Could be nute burn, pH imbalance.

1 Like

Also looks like you’re pretty far into flowering if that’s the case it could be normal yellowing of the Leaves near the end.

My first suggestion is ph … if not that … have you checked your run off ? What’s that ph s d ppm? Are you in final flush? If you aren’t a d it’s not ph. It’s probly a nutrient lockout… or deficiency/toxicity …

I would flush and judging by that pic you should have already been dialing down the nutes… I’d feed with light solution

1 Like

I started flushing it a week or so ago, it has 2 weeks left on it’s flower. What’s I s, d, and how does ppm work, I have some pH up and down coming today. What light solution should I use. Growweedeasy I think says it’s a cooler deficiency and the one with the yellow leaves a calcium deficiency.

Yea looks about right but if your flushing they are going to start looking they are dieing

So what should I do

If your in your final flush it’s ok that’s the plant is supposed to fade off and die like that it’s the plant sucking up the last nutrients stored

Well I actually started flush really early it has two weeks left in grow and I don’t think I was supposed to flush it until now or a little later. I accidentally started flush a week and a half ago. Is that bad

1 Like

That’s not all that bad do t worry … most soil growers I know do a three week flush and that’s included with the flower time

Ok, I’ll see if the pH is off in the meantime and make sure it’s all good

1 Like

Yea you should still ph the water

2 Likes

My pH is at 7.5-8 but my water pH is between 5.0-6. the pH won’t change though. What should I do

1 Like

So what you should be doing if phing the water coming out and then offset that number with what you ph going in … soil is a little different if you have a good soil the buffers in them will adjust the ph themselves… but don’t overthink just ph the flush water your good

2 Likes

Ok, I thought you’d just have to put in lower pH water in the soil

No always go with 6.5. It’ll work every time. I’ve been doing it this way for years with no issue. That said I use good soil as well. Fox farms ocean forest :+1::v:

That’s what I use and the RO water has a good pH by default but the soil pH is still higher