Red dots all over fan leafs

Why do I have red dots all over my plants fan leafs. I called grobo support and sent in pictures was told to change the water more often. Not helping at all actually getting worse. Can any one help Bc grobo support can’t. I believe it’s a calcium deficiency.

3 Likes

Assuming you are only using distilled water and nutes are being dispensed correctly, this could be some kind of fungus. Have Grobo support check on your pH and EC probes. The best way to get rid of this problem is carefully washing the stem and leaves with a diluted solution of water and mild soap. Check that your fans are also working properly. Good luck!

1 Like

How often are you changing your water, were you not doing it once a week? Could be fungus if your res temps are really high. Do you know the temp of your environment? I’m thinking like some the pH might have been off for a little bit could be a couple things.
If your ph isn’t within range it won’t be able to process the nutrients properly which in turn would lead to not getting cal.

2 Likes

I use distilled water. Have been changing the water every week and I have switched over to every 4-5 day.

1 Like

@Scoutpotter,

  • ((#Welcome)): :wave::wink:

  • (SorryThisHappenedToYou):

  • ((#YourLeavesAreTalking)): :brown_circle: =

  • >((#PHprobe)): ((#PHsensor)):

  • (I would start with checking your [PHprobe] [PHSensor]):

--

:brown_circle: :fallen_leaf:


2 Likes

I had this issue recently and support would adjust my nuts but nothing changed. I planted another pod and the same thing happened. After testing the pumps of each bottle over the phone with support, number 4 hose was clogged at the pump. I had to grab the inlet and outlet tube of every bottle by the pump, and pull each one in a flossing motion. It worked for me.

3 Likes