Purple MAC +60. WTF :)

60 days or so in and thinking I should restart… plant is growing but compromised. Most leaves are curling or clawing. Lots of them exhibit a weird trait; only half of the leaf seems to grow… there are a few healthy leaves here and there…

Looking for feedback on rip/replace and thoughts on what went wrong this round so I can avoid repeating…

Thanks everyone in advance!

!

2 Likes

1 Like

1 Like

1 Like

@MyTake23,

  • (SupportTicket [:ticket:] ):

  • (This is New, Might you look for bugs, Under What are left of your leaves and down the shaft): :thinking:

  • (What kind of water are you feeding her with):? :question:

  • (Did you use any extra additives):? :question:


(ForSupportHelp): (ClickHere):

--

  • (SorryThisHappenedToYou): (ProvideThemWithAPicture): (TheyWillSortThisOutForYou): (ShareThisTopicWithThem): (SaveYourPlant): (ItMayNotGetWorse): -But- (JustInCase):

  • ((#Ticket)): :ticket::tickets:(:point_down:)

https://support.grobo.io/hc/en-us/requests/new

[ https://support.grobo.io ]:

--

  • ((#KeepUsPosted)): :pen::computer::pencil2::notebook:

  • (KeepFeedingTickets): :ticket: :tickets:

[ https://www.allgrowers.com/search?q=ForSupportHelp%20 ]:

--

:crossed_fingers::crossed_fingers:


--

:infinity:


2 Likes

New is a word for sure lol. Havent seen this before.
@Stephen might be up your alley

2 Likes

I’m using RO water and adding 2.5 cc of Hydro Guard with each refill cycle. Nothing additional. Don’t see any signs of bugs that I can see with the naked eye.

1 Like

Someone on reddit has a plant like this! The freakshow! Freakshow

2 Likes