Please help, Rusty leaves and curling leaf tips

My plant is looking rough,

she’s having issues with cal/mag so I’ve already added started adding that to the weekly dosing after drain/fill. I also add small dosings of hydroguard and recharge during that time. I put in a support ticket today, but hoping someone can help me here so I don’t have to wait until Monday for an answer.

1 Like

It may be smart to wait for your ticket because at this point it looks like phosphorus deficiency.
You may have to flush your system if you have already checked calibration of your probes.
Read through this until one of the champions can confirm.

2 Likes

I would drain and refill right away every day until the problem is fixed.

4 Likes

Would you disconnect the nutrients?

1 Like

It looks like a calmag issue … you have some intervenial chlorosis going on which is a sign of mag deficiency… but that’s my opinion … that could also be because of ph… I’d check if ph is good then maybe think about a calmag adjustment if the it’s not the ph …

2 Likes

Not seeing bubbles in the pic, is your air pump running or was that pic taken when it was filling?

2 Likes

I just checked and it’s running thankfully lol it took me way to long to right this response, I’m way to high :joy::joy:

3 Likes

I think this sign is for Phosphorous deficiency.You need to add Phosphorous in the plant pot.

2 Likes

Should I use this?

1 Like

1 Like

@Rx-78-2,

Sorry, this is happening to you:

((#Ticket)): :ticket::tickets:

https://support.grobo.io

--

((#KeepUsPosted)): :pen::computer::pencil2::notebook:

--

:crossed_fingers::crossed_fingers:


@nana,

((#Welcome)):

:wave::wink:

--


I don’t know how to clean out water from your Sensor?: Sounds like another Ticket :ticket::tickets:

((#ISearchedIt)): :spider_web::computer::computer_mouse:

Conductivity Sensor Cleaning . Soak the sensor in 5 - 10% Hydrochloric acid (HCl) in water solution. for 5 - 10 minutes, then rinse.

((#Cleaning)): :bathtub:

--


2 Likes

EC looks like it has a bunch of nasty recharge water in it, will this effect the readings? And how do I clean it out? Thanks

2 Likes

Weird, and I doubt that’s good. You’ll need to submit a ticket ASAP @Stephen

3 Likes

I just put a ticket in last night. I noticed it while cleaning and doing a health check on my PH sensor.

2 Likes

Have you harvested already?

1 Like

Negative, I’m on day 9/37 of flowering. This plant is not looking good. I’m not getting my hopes up for a good harvest since all the issues i’ve run into with this grow. The thing I am taking away from this is knowledge for my next grow.

3 Likes

I didn’t think it was ok to clean during a grow? I really hope they check your ticket soon! Your sensor does look bad but I hope your still keeping them wet so they can be saved. Plants are resilient so hang in there!

3 Likes

I don’t think a clean will harm it. You’d have to recalibrate anyway so should be alright

2 Likes

After cleaning the PH sensor and doing a health check I put both probes back into the reservoir to keep them wet. I’m going to wait until support answers my ticket to clean the EC. And thanks I hope my plant does pull through. :crossed_fingers:

3 Likes

Keep us posted! :eyes::seedling:

3 Likes