I think something's wrong. HELP please

Hey Guys,
I noticed my leaves starting to yellow. What does this mean.

1 Like

I’m guessing a nitrogen deficiency and/or magnesium deficiency. Have the nutrients from bottle 4 been dispensed?

3 Likes

How are your roots looking? Here is a link to assist in identifying and fixing your issue:

2 Likes

If I had to guess by looking at all the photos from the link SWSVIC shared, I’d guess Iron Deficiency.

2 Likes

Thank you so much

2 Likes

Go ahead and submit a support ticket if you haven’t already done so. I’m sure that the Grobo team can weigh in and help you remedy your plant as well!

1 Like

Okay, my plant is starting to outgrow my grobo, what should I do?

1 Like

Hey @Tre-moe

Can you post a picture so we can better evaluate your situation?

2 Likes

What day are you on overall and what phase/day are you on?

I’m on day 79, im suppose to start the just water (no nutrients phase like next friday. But its touching the top, and the hot light is burning my leaves

Is that an old pic? It doesn’t appear to be near the top. Day 79, touching the top, and there are no flowers on your plant… Something is off here Tre. Obviously don’t let it go into flush as you will end up with no bud. Can you post another pic showing the top?

2 Likes

Lolollol :joy::joy: @SWSVIC

1 Like

1 Like

I don’t see any buds, or pistols. Definitely don’t start flushing unless there are buds hiding somewhere.

2 Likes

@Tre-moe,

  • ((#Welcome)): :wave: :wink:

[ https://www.allgrowers.com/search?q=TooTall ]

--


Hey @Tre-moe,

I’m wondering if you are running an auto recipe on a photoperiod dependent plant. Contact us at support@grobo.io and we can help out.

Cheers,
Stephen

2 Likes