Durban Poison early vegetation state

Just posting my results so far. I’m inspecting on a regular basis… daily that is :fire: and this is progress so far.

9 Likes

Looking good. :herb: :ok_hand:

3 Likes

Looks good… Hey I just did a Google search… check out Durban Poison in it’s natural habitat! Just wow… this is the tallest strain I’ve ever seen!

Hope it doesn’t get that big on you in the Grobo LOL :slight_smile:

This is some straight PRAY TO THE SUN GODS type shit, so amazing.

Killer strain tho, one of the only ones that naturally has some THCv in it!

9 Likes

OMG :eyes::eyes::eyes: Hope not… But when that’s said, pretty stunning.

3 Likes

Holy smokes!

2 Likes

That’s crazy tall. Looking good

2 Likes

I’m getting small yellow marks on the leaves, could anyone tell me why that is?

2 Likes

This is very common with Grobo grows, typically this is related to a shock in absorption of the plants nutrients, typically only happens with the lowest leaves. I had a little of this myself in my last grow and have seen it before. It doesn’t look pretty, but soon your plant will start growing more and more and you’ll forget it’s even there. The stuff up top should look green and unblemished. If this ends up progressing to leaves further or gets really bad, send in another pic.

Just to clarify though, as this can ALSO possibly be a Cal/Mag deficiency in your plant, is your Bottle #5 dispensing ?

4 Likes

Hi Thanks for the response. Appreciate that.

No only bottle 2 acidic has been used…

What day is your recipe on? I think you should have had #3/#4 and #5 dispensed by now!

If none of those bottles has dispensed, it’s probably not a nutrient shock but more or less a deficiency!

I would check to make sure those hoses aren’t kinked up in any spots, and possibly do a fresh drain and fill!

You might also be wise to send a support ticket into Grobo to make sure everything is okay on their end, they can help confirm if the bottles are not dispensing.

3 Likes

Thanks for the heads-up… Yeah only #2 has had usage… None of the other bottles and there are no kinks on the hoses.
I’ll let support know.

3 Likes

Which day are you in on your recipe? Are you at least past Early Vegetation day 4/10 ? My first nutrients dispensed last night at Germination 8/10 so I think you definitely should have them using by now

1 Like

When was your last water change?

1 Like

I’m.at 6/14 early vegetation and water has just been changed accordingly to instructions.

3 Likes

If you’re certain that absolutely none of those bottles have been used yet, not just a little bit, then you could possibly attempt doing a fresh drain and fill with the same water inside and maybe it would work this time for the nutrients? Worst thing that could happen you just take the water out and put it back in as is?

Also, maybe you can try before the drain and fill, power cycle your unit? Unplug the cord in the back and wait 30 seconds, replug, this might help… lots of errors fixed this way

4 Likes

The nutrients started kicking in… And grow is like doubling every day now. Looking good.

6 Likes

Hell yes! Looks good!

2 Likes

Pretty amazing how it grows now… Every day is almost a double…

7 Likes

What day is this? :ok_hand:t2::facepunch:t2::blush:

2 Likes

Day 22 since seed went in.

3 Likes