Day 18 Late Bloomer or Not Growing?

Hey fellow growers! I’m on day 18 and for some reason I feel like my plant isn’t growing at the speed the app is saying it should.

Says I should see “3 to 4 sets of leaves” and roots that extend down into the reservoir. I’m only seeing 2 sets of leaves and a single root and not much growth at all in the last week.

What do you think? Does this little guy look like it’s all right?
The water was just adjusted to the middle sensor so maybe I’ll see some growth soon.

Thanks for any guidance!!

1 Like

Something is definitely wrong! Send in a ticket asap because the plant should not be this long.

1 Like

damn, I figured. You mean the stem of the plant shouldn’t be that tall?

1 Like

Right! This is my plant around the same growth time. Don’t panic just yet!!! Ask the pros. @Stephen, @ToddYYC, or @chris_barfield

https://s3.amazonaws.com/grobomvp-uploads/uploads/images/000/003/590/original/4A4FE506-853E-4317-8A5F-387C68B6A842.jpeg?1565197507

1 Like

Thanks @Bplatinum9 !
@Stephen @ToddYYC @chris_barfield can this little dude be salvaged or am I doomed to start over?

1 Like

Put that ticket in and keep me posted!

1 Like

If you havent ticketed I wouldn’t waste the effort on what will now be a stunted plant. Start again. However. Contact support@grobo.io to fix your issue. That visual look to me means your lights are not staying on and could be too hot and shut off thus malnutritioning the plant. Support can see that and advise.

2 Likes

Thank you!

I second @ToddYYC start over. Try germinating before putting in pod :call_me_hand:

I just followed the YouTube video and I’ve had 100% success rate

2 Likes